Skip to main content



Cornell Box sync client upgrade

Beginning the week of July 14, Box will begin notifying individuals using an older version of the sync client Sync 3 that they should upgrade to the latest version, Sync 4 for Windows or Mac. Administrative privileges to the computer are needed to upgrade to Sync 4, so people using a managed computer will require assistance from their technical support provider. After upgrading to Sync 4, future updates will occur automatically, without the need for administrative authorization.

For more information go to: Cornell Box sync client upgrade | IT@Cornell News.

Print Friendly, PDF & Email

Comments

Comments are closed.